# 模块白名单

# 为什么显示模块暂不支持?

通常情况下有两个原因:

  1. 只有在太极阳下才能使用这个模块,而你处于太极阴模式。有一些模块比如重力工具箱、绿色守护,他们需要拦截系统进程才能起作用,而太极阴做不到这一点,因此会提示暂不支持;实际上也永远不可能支持(除非你切换到太极阳)。
  2. 这个模块不在太极的模块白名单之中。

# 什么是模块白名单,为什么有这个?

只有在模块白名单中的模块才会被太极加载,进而生效。

为什么要这么做? 为了安全。

类 Xposed 模块有着极高的系统权限,并且它很难被标准的 Android 权限模型所限制。打个比方,模块可以作用于系统进程,然后以系统的身份去发出网络请求,如果你仅仅针对这个模块本身关闭掉网络权限,那这个操作对它没有任何作用,它依然可以访问网络,并且你很难追踪到它。更可怕的是,模块可以拿着它作用的宿主(可以是任何高权限的系统进程)做任何事情,包括恶意行为。事实上,已经有一些模块这样干了,比如之前爆料的应用控制器

为了最大程度地阻止这个缺陷,太极通过白名单来限制模块:只有被证明是安全的模块才能在太极中生效。

另外,白名单还有一个额外的好处:可以阻止模块被破解,从而保护开发者的利益。

# 如何把模块加入太极白名单?

  1. 打开 太极管理后台 然后注册一个账号。
  2. 上传你想要试用的模块。
  3. 等待管理员来审核模块。
最后更新: 2020-2-11 13:39:41